Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 21, 2023 - 03:01 EDT
Scheduled
The Northpass Platform will be undergoing maintenance at this time. The platform will be inaccessible for all users (administrators, managers and learners) for the duration of this maintenance period. We appreciate your patience and understanding during this time.
Posted Jun 19, 2023 - 14:50 EDT
This scheduled maintenance affected: Northpass App - AWS.