Salesforce Connection failures

Incident Report for Northpass

Update

We are working with Salesforce to restore functionality as quickly as possible. However, our Native platform remains operational.
We will continue to share updates here as soon as we have them.
Posted Nov 21, 2025 - 22:00 EST

Update

We are working with Salesforce to restore functionality as quickly as possible. However, our Native platform remains operational.
We will continue to share updates here as soon as we have them.
Posted Nov 21, 2025 - 13:58 EST

Update

We are continuing to work to restore functionality as quickly as possible. We will share updates here as soon as we have more information.
Posted Nov 21, 2025 - 10:26 EST

Identified

We’ve identified the authentication issue that is preventing our Salesforce app from connecting. Our team is working to restore functionality as quickly as possible and no data loss is expected.
We will share updates here as soon as we have more information.
Posted Nov 21, 2025 - 10:08 EST

Investigating

We are investigating reports of Salesforce Connection failures and we will update here as soon as we have more details.
Posted Nov 21, 2025 - 10:02 EST
This incident affects: Northpass App - AWS and Northpass App - Azure.