Intermittent errors — Azure East US platform incident

Incident Report for Northpass

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 22:49 EDT

Update

We are continuing to monitor the upstream service provider for status updates.
Posted Apr 24, 2026 - 16:29 EDT

Monitoring

We are tracking an active Microsoft Azure incident in the East US region that is causing intermittent connection and DNS errors across our platform. Some users may experience delayed actions, failed webhook deliveries, or transient errors while we ride out the upstream issue.
Posted Apr 24, 2026 - 12:06 EDT
This incident affected: Northpass App - Azure.