Application Performance Issues

Incident Report for Northpass

Resolved

The incident has been resolved.
Posted Mar 21, 2022 - 10:14 EDT

Monitoring

We addressed the problem and are monitoring the situation.
Posted Mar 21, 2022 - 09:50 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 21, 2022 - 09:26 EDT

Investigating

Northpass is currently experiencing performance issues. You may notice the application working slower than usual.
Posted Mar 21, 2022 - 09:09 EDT
This incident affected: Northpass App - AWS.