Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 14, 2024 - 02:00 EDT
Scheduled
The Gainsight Customer Education platform has planned a scheduled maintenance for Backend Data Stores. During this maintenance window, users will not be able to use the application. Soon after the maintenance, all functionality will return to normal.
Posted Sep 03, 2024 - 05:04 EDT
This scheduled maintenance affected: Northpass App - AWS.