Azure - Elevated API Errors

Incident Report for Northpass

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 17:45 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 29, 2025 - 17:05 EDT

Monitoring

As a result of the fix implemented by Microsoft Azure, the outage is now recovered. We observed recovery on our end at 20:20 UTC as our platform is now available and operational. However, we continue monitoring recovery status and will provide updates within the hour.
Posted Oct 29, 2025 - 17:02 EDT

Update

The outage remains in progress.
Microsoft Azure has confirmed an active incident affecting Azure Front Door (our global load balancer), which continues to disrupt traffic routing to our backend services.

Our platform remains fully unavailable. However, a fix is currently being implemented by Microsoft Azure and we are awaiting the result.
We are in continuous contact with Microsoft Azure support and will restore services as soon as the issue is resolved on their side.
Posted Oct 29, 2025 - 15:37 EDT

Update

The outage remains in progress.
Microsoft Azure has confirmed an active incident affecting Azure Front Door (our global load balancer), which continues to disrupt traffic routing to our backend services.

Our platform remains fully unavailable while we wait for a fix from the cloud provider.
We are in continuous contact with Microsoft Azure support and will restore services as soon as the issue is resolved on their side.
Posted Oct 29, 2025 - 14:20 EDT

Identified

We have confirmed that the outage is caused by an ongoing issue with Azure Front Door (our global load balancer) on the Microsoft Azure side.

This issue is impacting traffic routing to our backend services, resulting in a full platform outage.
Our team remains in contact with Microsoft Azure support and is monitoring their mitigation progress.
Posted Oct 29, 2025 - 12:52 EDT

Update

We are currently experiencing a full Azure platform outage.
Initial investigation indicates the issue is related to Azure Front Door (our global load balancer) and originates on the Azure side.

We are monitoring the situation closely and are in contact with Microsoft Azure support.
Posted Oct 29, 2025 - 12:27 EDT

Investigating

We're experiencing an elevated level of API errors on Azure platform and are currently looking into the issue.
Posted Oct 29, 2025 - 12:01 EDT
This incident affected: Northpass App - Azure.