Application Outage
Incident Report for Northpass
Resolved
This incident has been resolved.
Posted Sep 06, 2023 - 11:05 EDT
Identified
We are aware and have identified an issue that is causing the application to sometimes fail. We are actively working to resolve the issue and expect to have this resolved shortly.
Posted Sep 06, 2023 - 10:29 EDT
This incident affected: Northpass App - AWS.