Application Outage

Incident Report for Northpass

Resolved

Between 14:22 and 14:46 EDT today, our entire application was unavailable due to an unexpected memory exhaustion in our backend layer.

Root Cause:
A high-volume enrolment process caused backend cache errors leading to an "Out of Memory" condition.

Preventative Measures

Script Throttling: We'll introduce rate-limiting for large-scale data loads.
Capacity Expansion: Backend cache memory limits were increased.
Posted Apr 29, 2025 - 15:43 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2025 - 14:46 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 29, 2025 - 14:46 EDT

Investigating

We are currently investigating this issue.
Posted Apr 29, 2025 - 14:22 EDT
This incident affected: Northpass App - Azure.